Community Home

HP Forum

TechnologiesTopic CountRepliesLast Post

Immersive

Welcome to the Immersive developer community forum.
15245 months 2 weeks ago by sprout.dev@hp.com

PrintOS

PrintOS community discussion and support.
31371 week 4 days ago by bdieckman@inter-state.com

SmartStream SDKs

Improve production efficiency and produce high-value applications using HP SmartStream solutions.
453 months 5 days ago by andrewe@waratahgroup.com.au

Client Management Solutions

Community discussion and support for HP Client Management
00-

HP Client Management Script Library

Community discussion and support for HP Client Management Script Library
00-

HP JetAdvantage Developer Programs

This forum exists to redirect JetAdvantage Partners to the correct forum which is hosted on ZenDesk. Forum posts need to be directed to https://jetadvantage.zendesk.com/ which may also be accessed via the Support link in most JetAdvantage technology pages here on the portal.
402 weeks 17 hours ago by umango

PrintOS PrintBeat API

232 months 2 weeks ago by cstevens

PrintOS PrintBeat Jobs API

7161 week 4 days ago by bdieckman@inter-state.com

PrintOS SiteFlow API

422 months 1 week ago by fabri.ll@hotmail.com

Production Center REST API SDK

102 years 5 months ago by cstevens

Production Pro JDF SDK

286518 hours 5 min ago by cstevens

SmartStream Production Center Product & SDKs

317 months 1 week ago by cstevens

PPML SDK

111 year 3 months ago by ameliawilson

PrintOS Device API

2145 months 3 weeks ago by cstevens

Production Center JDF SDK

102 years 5 months ago by cstevens

SmartStream Production Pro SDKs

114 months 18 hours ago by cstevens

PrintOS Box API

441 year 11 months ago by cstevens

Mobile Scan SDK

This forum is for the purpose of discussing the Mobile Scan SDK; its uses and functionality across the iOS and Android platforms.
8203 weeks 5 days ago by Varadha

Recent Blog Posts

Shane Wall CTO: Ride the waves of innovation with us. Surf's up!
Epic Stories 22 May 2019
Shane Wall CTO: Ride the waves of innovation with us. Surf's up!
Welcome to the HP Inc. Developers' Portal. Here you will find insights into what HP has in store for developers. 3D printing. Blended reality. Software that makes hardware more useful. As HP creates SDKs and APIs, you will learn about them here first.
Extracting platform to softpaq mapping from security bulletins
HP Client Management 22 May 2019
Extracting platform to softpaq mapping from security bulletins
Second post in the Zombieload Special series. In this post, we consider an alternate way of working with security bulletins and the HP Client Management Script Library.

News and Events

19 Apr 2019
TLS 1.0 / TLS 1.1 Disabled by default in FutureSmart bundle 4.7.2 and later

The FutureSmart 4.7.2 firmware release changed the default availability of TLS protocol versions. The updated security profile for FutureSmart version 4.7.2 defaults to:

  • TLS 1.2 – Enabled
  • TLS 1.0 & TLS 1.1 – Disabled

 

The new TLS protocol defaults are applied in the following circumstances:

 

Devices purchased with FutureSmart bundle 4.7.3 and later

  • Use the new TLS defaults (TLS 1.0 / 1.1 disabled)

 

Devices updated to FutureSmart bundle 4.7.2  or later from FutureSmart 3 bundles or FutureSmart 4 bundles before version 4.7.2

  • TLS settings are not updated to the new defaults and maintain their current setting.

 

Performing the following device resets on FutureSmart 4.7.2 or later devices update the TLS  settings to the new defaults, overwriting any previously configured setting

  • Format Disk
  • Partial Clean
  • Cold Reset

Important Note: HP and 3rd party solution software may have a TLS 1.0 dependency requiring TLS 1.0 to be enabled / re-enabled for installation or to function properly after installation.   Details on how to do that can be found in the document here.

Important Note: FutureSmart bundle 4.7.2 is an interim firmware release only available from HP Support.

 

The following devices will ship with FutureSmart bundle 4.7.3 which have the new TLS defaults.

  • HP LaserJet Managed MFP E72525/ 30/35
  • HP Color LaserJet Managed E77822/25/30
  • HP LaserJet Managed MFP E82540/50/60
  • HP Color LaserJet Managed MFP E87640/50/60
19 Apr 2019
TLS 1.0 / TLS 1.1 Disabled by default in FutureSmart bundle 4.7.2 and later

The FutureSmart 4.7.2 firmware release changed the default availability of TLS protocol versions. The updated security profile for FutureSmart version 4.7.2 defaults to:

  • TLS 1.2 – Enabled
  • TLS 1.0 & TLS 1.1 – Disabled

 

The new TLS protocol defaults are applied in the following circumstances:

 

Devices purchased with FutureSmart bundle 4.7.3 and later

  • Use the new TLS defaults (TLS 1.0 / 1.1 disabled)

 

Devices updated to FutureSmart bundle 4.7.2  or later from FutureSmart 3 bundles or FutureSmart 4 bundles before version 4.7.2

  • TLS settings are not updated to the new defaults and maintain their current setting.

 

Performing the following device resets on FutureSmart 4.7.2 or later devices update the TLS  settings to the new defaults, overwriting any previously configured setting

  • Format Disk
  • Partial Clean
  • Cold Reset

Important Note: HP and 3rd party solution software may have a TLS 1.0 dependency requiring TLS 1.0 to be enabled / re-enabled for installation or to function properly after installation.   Details on how to do that can be found in the document here.

Important Note: FutureSmart bundle 4.7.2 is an interim firmware release only available from HP Support.

 

The following devices will ship with FutureSmart bundle 4.7.3 which have the new TLS defaults.

  • HP LaserJet Managed MFP E72525/ 30/35
  • HP Color LaserJet Managed E77822/25/30
  • HP LaserJet Managed MFP E82540/50/60
  • HP Color LaserJet Managed MFP E87640/50/60
19 Apr 2019
TLS 1.0 / TLS 1.1 Disabled by default in FutureSmart bundle 4.7.2 and later

The FutureSmart 4.7.2 firmware release changed the default availability of TLS protocol versions. The updated security profile for FutureSmart version 4.7.2 defaults to:

  • TLS 1.2 – Enabled
  • TLS 1.0 & TLS 1.1 – Disabled

 

The new TLS protocol defaults are applied in the following circumstances:

 

Devices purchased with FutureSmart bundle 4.7.3 and later

  • Use the new TLS defaults (TLS 1.0 / 1.1 disabled)

 

Devices updated to FutureSmart bundle 4.7.2  or later from FutureSmart 3 bundles or FutureSmart 4 bundles before version 4.7.2

  • TLS settings are not updated to the new defaults and maintain their current setting.

 

Performing the following device resets on FutureSmart 4.7.2 or later devices update the TLS  settings to the new defaults, overwriting any previously configured setting

  • Format Disk
  • Partial Clean
  • Cold Reset

Important Note: HP and 3rd party solution software may have a TLS 1.0 dependency requiring TLS 1.0 to be enabled / re-enabled for installation or to function properly after installation.   Details on how to do that can be found in the document here.

Important Note: FutureSmart bundle 4.7.2 is an interim firmware release only available from HP Support.

 

The following devices will ship with FutureSmart bundle 4.7.3 which have the new TLS defaults.

  • HP LaserJet Managed MFP E72525/ 30/35
  • HP Color LaserJet Managed E77822/25/30
  • HP LaserJet Managed MFP E82540/50/60
  • HP Color LaserJet Managed MFP E87640/50/60