HP Image assistant 5.0.2 Extraction issues

11 posts / 0 new
Last post
Author
Message
peter.jarnfors
Posted: 4 September 2020 - 12:24am
HP Image assistant 5.0.2 Extraction issues

Hi,

When i upgraded my HPIA from 4.5 to 5.0.2 my OSD didnt install any drivers. When I look at the logs of the install it says "unable to extract files from SoftPaq" on every Softpaq (13).

If I go back and install with the 4.5 version it works like a charm. I cant se that the switches has changed and this is the command I use.

HPImageAssistant.exe /Operation:Analyze /Selection:all /Action:install /OfflineMode:"\\Serverpath\Drivers\HP EliteBook x360 830 G7" /ReportFolder:"\\ad.boras.se\SCCM_repo\Drivers\Logs\%Computername%" /Logfolder:"\\Serverpath\Drivers\Debug\%Computername%" /SoftpaqDownloadFolder:.\HP EliteBook x360 830 G7 /BIOSPwdFile:currentbiossetuppwd.bin /noninteractive /Silent /Debug

Any ideas?

 

Mvh
Peter Järnfors

Top
Author
Message
raymond.hellber...
Posted: 28 September 2020 - 12:33am
I've got the same problem

I've got the same problem when using /SoftpaqDownloadFolder to an UNC or network path/share. Using local path all is okay, tearing my hair out here...

Top
Author
Message
txvalp
Posted: 1 October 2020 - 11:16am
Extraction path

Hi,

Peter:

On the example above, you do no thave quotes around the path in "SoftpaqDownloadFolder". Also, I don't think relative paths are supported, you may want to use an absolute path. I'll dig in further to see if we have any issues.

Raymond:

Are you also running 5.0.2?

 

Top
Author
Message
raymond.hellber...
Posted: 2 October 2020 - 3:37am
Yes, 5.0.2

txvalp: Whatever I try, it will never extract to network shares/UNCs. Even tried different servers and shares. The folder rights are okay because the softpacks are downloaded to UNCs and the computers are logging okay to UNCs. But extraction - no.

Have also enabled object access auditing on the shares, there is no indication of missing rights to anything.

Top
Author
Message
peter.jarnfors
Posted: 5 October 2020 - 10:43pm
Path

Hi, thanks for reponding,
I have tried the Quotes and an absolute path. 

With HPIA 5.0.2
Command line "C:\_SMSTaskSequence\Packages\BOR00909\HPImageAssistant.exe"  /Operation:Analyze /Selection:all /Action:install /OfflineMode:"\\server\SCCM_repo\Drivers\HP EliteBook x360 830 G7" /ReportFolder:"\\server\SCCM_repo\Drivers\Logs\5CG0306RSD" /Logfolder:"\\server\SCCM_repo\Drivers\Debug\5CG0306RSD" /SoftpaqDownloadFolder:"C:\HPIA\HP EliteBook x360 830 G7" /BIOSPwdFile:currentbiossetuppwd.bin /Silent /Debug returned 255

With HPIA 4.5.8.1
"C:\_SMSTaskSequence\Packages\BOR008DF\HPImageAssistant.exe"  /Operation:Analyze /Selection:all /Action:install /OfflineMode:"\\server\SCCM_repo\Drivers\HP EliteBook x360 830 G7" /ReportFolder:"\\server\SCCM_repo\Drivers\Logs\5CG0306RSD" /Logfolder:"\\server\SCCM_repo\Drivers\Debug\5CG0306RSD" /SoftpaqDownloadFolder:"c:\HPIA\HP EliteBook x360 830 G7" /BIOSPwdFile:currentbiossetupwd.bin /silent /Debug returned 3010

Version 4.5.8.1 works with absolute and relative paths. 5.0.2 wont work for me with either way.

Top
Author
Message
txvalp
Posted: 2 October 2020 - 9:21am
What is your path length?

I saw in indication we may have a problem with path lenghts, which we are trying to track down. What is your UNC path length? Can you try temporarily shortening it to max of about 50 characters, and see if that solves the problem? 

 

Top
Author
Message
raymond.hellber...
Posted: 3 October 2020 - 6:42am
Path lenght is under 50.

The command I use is: "c:\hpia\HPImageAssistant.exe" /Operation:Analyze /Action:Install /Category:All /Selection:All /Silent /ReportFolder:"\\server-3\HPIAlogs\%computername%" /SoftpaqDownloadFolder:"\\server-3\hppacks". The local share path for "hppacks" on the server is also short: D:\HP\HpPacks. So there should be no path issues involved.

Top
Author
Message
peter.jarnfors
Posted: 7 October 2020 - 4:33am
Hi Raymond,

 

Looks like your /Softpackdownloadfolder points to a server. The /Softpackdownloadfolder points to where you put the downloaded SoftPaqs on your computer before HPIA installs them (/Softpackdownloadfolder:C:\HPIApack). 

If you have a offline repository you need to have that option in the Command "OfflineMode:\\Server-3\hppacks" if you only have 1 big repository for all models

Top
Author
Message
raymond.hellber...
Posted: 7 October 2020 - 3:49am
No more responses on this ?

Oaky, reverting to Softpaq Download Manager and SSM then, the current HPIA obviously have som serious flaws.

Top
Author
Message
raymond.hellber...
Posted: 7 October 2020 - 5:29am
Oaky, will try that.

-thanks.

Top
Author
Message
txvalp
Posted: 7 October 2020 - 8:34am
Path bug

Sorry for the delayed response, was waiting for a test result.

In general, I am told there is a bug in the command line that may be affecting you. Someone will follow up with more details and fix schedule.

In the meanwhile, for the short duration it may help if you map a drive and use a drive letter.

 

Top
Please login to comment