Generic Failure retriving HP_BIOSSetting class

4 posts / 0 new
Last post
Author
Message
keefem@ebnhc.org
Posted: 4 February 2020 - 12:53pm
Generic Failure retriving HP_BIOSSetting class

I am trying to edit BIOS settings across multiple models using powershell, however, on my HP EliteDesk 800 G1 DM i get the following

 

PS C:\WINDOWS\system32> $HPBiosSettings = Get-WmiObject -Namespace root/hp/InstrumentedBIOS -Class HP_BIOSSetting
Get-WmiObject : Generic failure 
At line:1 char:19
+ ... sSettings = Get-WmiObject -Namespace root/hp/InstrumentedBIOS -Class  ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [Get-WmiObject], ManagementException
    + FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

I have tried updateing the bios and removing the setup and power on passwords, I am running powershell as an admin, and I am on windows 10 enterprise version 1903

Top
Author
Message
txvalp
Posted: 5 February 2020 - 8:36am
Does it work outside of powershell?

Could you try the following in a non-powershell console:

wmic /namespace:\\root\HP\InstrumentedBIOS path HP_BIOSsetting get

 

That takes powershell out of the equation. If it still fails (mnaybe with an Invalid namespace message), there may be some WMI corruption. If so, if you have a test machine you can use, you can try rebuilding the WMI repository. See for example here: https://success.solarwindsmsp.com/kb/solarwinds_n-central/Re-sync-or-rebuild-the-WMI-Repository. Please do not try on a production machine, since especially the last step (the script that runs mofcomp) can cause sideffects. I would incrementally try the steps in that article.

 

 

 

 

 

Top
Author
Message
keefem@ebnhc.org
Posted: 5 February 2020 - 11:34am
Similar error

Using WMIC gave a similar error. This is a fresh image of Win10, but on other models these commands work fine. It is the 800 G1s that give the issue

PS C:\WINDOWS\system32> wmic /namespace:\\root\HP\InstrumentedBIOS path HP_BIOSsetting get
wmic : Node - 2UA53412FZ
At line:1 char:1
+ wmic /namespace:\\root\HP\InstrumentedBIOS path HP_BIOSsetting get
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Node - 2UA53412FZ:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
 
ERROR:
Description = Generic failure

 

Top
Author
Message
txvalp
Posted: 5 February 2020 - 7:38pm
Something is definitely wrong

Something is definitely wrong in the WMI layer. The only time I've seen this is when some other application was hammering WMI, which was causing it to behave badly (WMI is not good under stress).

Do you see any interesting errors either in the event view System log, or under Aplication and Services logs / Microsoft / Windows / WMI-Activity?

 

 

Top
Please login to comment