Issues downloading SP113339 through HPIA?

3 posts / 0 new
Last post
Author
Message
AlexandreP
Posted: 12 August 2021 - 5:16pm
Issues downloading SP113339 through HPIA?

Hi all!

So I have a bunch of HP EliteDesk 800 G5 DM on which I've run HP Image Assistant 5.1.2. HPIA exited with error code 8199 ("The SoftPaq download failed").

C:\WINDOWS\ccmcache\4\HPImageAssistant.exe /Action:Install /Category:BIOS,Drivers,Firmware,Accessories /debug /InstallType:AutoInstallable /lang:en /Operation:Analyze /ReportFolder:"C:\HPIA\Report" /Selection:All /silent /SoftpaqDownloadFolder:"C:\HPIA\Download" 

Using the debug log, it seems the softpaq that cannot be downloaded is SP113339. I can see 15 attempts at downloading 'https://ftp.hp.com/pub/softpaq/sp113001-113500/sp113339.exe?hpia=5.1.2&wf=1&pn=HP+EliteDesk+800+G5+Desktop+Mini&osv=10.0.18363&osa=64&op=4&m=cl'

  • Since HPIA has been able to retrieve the updates list from 'https://hpia.hpcloud.hp.com/ref/platformList.cab', I'm pretty sure I can exclude Internet access problems. Moreover, other softpaqs have been downloaded successfully at the same time on the same device (i.e. 'https://ftp.hp.com/pub/softpaq/sp114001-114500/sp114236.exe' is downloaded without issue, and later installed successfully);
  • When HPIA runs, I can observe that SP113339 gets downloaded (a file 'C:\HPIA\Download\sp113339.exe' gets created, and its size grows up to 437,511 KB), but it gets deleted and downloaded again. This cycle is repeated 15 times;
  • I manually took a copy of sp113339.exe after it finished downloaded and before it gets deleted. I then compared its SHA256 filehash with the listed in the CVA file (https://ftp.hp.com/pub/softpaq/sp113001-113500/sp113339.cva). The hashes match;
  • I manually downloaded SP113339 from support.hp.com, and compared its filehash with my copied-SP113339 filehash. They match;
  • I extracted the content of my copied-SP113339.exe file('sp113339 - Copy.exe' /s /e /f C:\HPIA\SP113339). The content is extracted successfully -- the file does not seem to be malformed;
  • I re-executed HPIA using /Action:Download. I produced the same behavior -- 15 download attempts before ending with RC = 8199;
  • I downloaded HPIA 5.1.1, and manually executed the previous command -- same output: 15 download attempts, and RC = 8199. The issue might not be tied to a specific HPIA release;
  • When I graphically ran HPIA, I noted that SP1133339 contains 5 elements, each resulting in a failed download attempt; 3 attempts per element:
    • Intel(R) Active Management Technology - SOL (COM3)
    • Intel (R) Management Engine Interface
    • Generic software component
    • Generic software component
    • Generic software component

Any idea? Anyone encountering the same behavior?

Thanks! :)

Top
Author
Message
jchou
Posted: 23 August 2021 - 12:10pm
Re: Issues downloading SP113339 through HPIA?

Hi, There was a problem with some SoftPaqs recently where the hash numbers did not match so the CVA files needed updating. If HPIA downloads a SoftPaq and the hash numbers do not match, it will delete the file. We downloaded SP113339 with HPIA today and everything is working fine.

Top
Author
Message
AlexandreP
Posted: 23 August 2021 - 2:16pm
Re: Issues downloading SP113339 through HPIA?

Thanks for the reply. I also observed a 404 error when trying to acquire SP111991 last Friday. Everything seem alright as of today for both SP113339 and SP111991.

Top
Please login to comment