Can't install HPLIP 3.21.2 on Linux Mint 20.1 ...

4 posts / 0 new
Last post
Author
Message
elvio.forums
Posted: 7 March 2021 - 4:26am
Can't install HPLIP 3.21.2 on Linux Mint 20.1 ...

Hi!

 

I have been installed Linux Mint 20.1 installed on my PC.

When I try to install HPLIP 3.21.2 (to replace actual hplip-3.20.11),  a red message says that 3.21.2 is not compatible with mint 20.1.

In the topic "Linux distributions supported by the automatic installer", says:

...

Linux Mint (17, 17.1, 17.2, 17.3, 18, 18.1, 18.2, 18.3, 19, 19.1,19.2,19.3,20.04)

...

but, the version sequence is: Mint 19.3, 20 and 20.1, not 20.04. Apparently, "20.04" refers to Ubuntu.

Perhaps making the correct identification of the Mint version, at this moment 20.1, can solve this issue.

 

Thank you.

 

Top
Author
Message
lagunaweb23
Posted: 29 April 2021 - 7:41am
Re: Can't install HPLIP 3.21.2 on Linux Mint 20.1 ...

Hi,

same issue here, but all these dependencies  not available could explain the error:
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
libjpeg              base                 REQUIRED            
libtool              base                 REQUIRED            
cups-devel           base                 REQUIRED            
cups-image           base                 REQUIRED            
gcc                  base                 REQUIRED            
libpthread           base                 REQUIRED            
libusb               base                 REQUIRED            
sane-devel           scan                 REQUIRED            
libavahi-dev         scan                 REQUIRED            
xsane                scan                 OPTIONAL            
libnetsnmp-devel     network              REQUIRED            
libcrypto            network              REQUIRED            
python3-notify2      gui_qt5              OPTIONAL            
python3-pyqt4-dbus   gui_qt4              OPTIONAL            
python3-pyqt4        gui_qt4              REQUIRED            
python3-pyqt5-dbus   gui_qt5              OPTIONAL            
python3-pyqt5        gui_qt5              REQUIRED 

Thanks for help!
 

Top
Author
Message
warren.volkmann...
Posted: 3 May 2021 - 10:02am
Re: Can't install HPLIP 3.21.2 on Linux Mint 20.1 ...

The HP PrintOS forum is not the correct forum for your question. Please submit your issue to the HP Linux Imaging & Printing forum hosted on LaunchPad:

https://launchpad.net/hplip/+addquestion

(It looks like it is for Ubuntu questions, but the LaunchPad forum supports all Linux distros.)  

Top
Author
Message
warren.volkmann...
Posted: 3 May 2021 - 10:09am
Re: Can't install HPLIP 3.21.2 on Linux Mint 20.1 ...

The delay in answering your question is a result of it being in the wrong Forum.  The HP PrintOS forum does not handle Linux OS questions. Please submit your issue to the HP Linux Imaging & Printing forum hosted on LaunchPad:

https://launchpad.net/hplip/+addquestion

(It looks like it is for Ubuntu questions, but the LaunchPad forum supports all Linux distros.)  

Top
Please login to comment