Convert AutoCopyArchive . bin to . Jpeg error

1 post / 0 new
Author
Message
york
Posted: 28 September 2020 - 12:57am
Convert AutoCopyArchive . bin to . Jpeg error

Hi,

We used the MaserDecompTool  to convert  * . bin to * . Jpeg from HP MFP machine. 

All most files can convert successfully but We have some files failure , Please see below.

How to fix it ?

====================================================================================================================

E:\source\OXPd\AutoCopyArchive\HPImage2PDF>MaserDecompTool.exe -m "c:\temp\Auto_metadata_21-32.xml" -b "C:\temp\Auto_image_21-32.bin" -o "C:\temp\Auto.jpeg"

Using metadata file:c:\temp\Auto_metadata_21-32.xml
Using binary file:C:\temp\Auto_image_21-32.bin
Using output file: C:\temp\Auto.jpeg
TSLIB: === BEGIN CLASS STATE DUMP =======
TSLIB: NumRowsOfTiles_ = 107
TSLIB: StripRetrieved_ = 1
TSLIB: LeftColumnsToCrop_ = 0
TSLIB: RightColumnsToCrop_ = 0
TSLIB: TopRowsToCrop_ = 0
TSLIB: BottomRowsToCrop_ = 0
TSLIB: Num non-NULL tags remaining = 106
TSLIB: NumOriginalColumnsConsumed_ = 0
TSLIB: NumOriginalRowsConsumed_ = 0
TSLIB: OriginalImageWidth_ = 4800
TSLIB: OriginalImageHeight_ = 6848
TSLIB: BitsPerPixel_ = 8
TSLIB: NumPlanes_ = 1
TSLIB: TileLength_ = 64
TSLIB: Rotation_ = 0
TSLIB: LeftPixels_ = 0
TSLIB: RightPixels_ = 0
TSLIB: TopPixels_ = 0
TSLIB: BottomPixels_ = 0
TSLIB: VertFlip_ = 0
TSLIB: PadMultiple_ = 64
TSLIB: RetrievalStripHeight_ = 64
TSLIB: LayerPlacementX_ = 0
TSLIB: LayerPlacementY_ = 0
TSLIB: LayerOrder_ = 0
TSLIB: LayerAlpha_ = 255
TSLIB: LayerIsSolidWhite_ = 0
TSLIB: LayerWatermarkDetected_ = 0
TSLIB: LayerIsIpspPage_ = 0
TSLIB: UncompOffsetResetInterval_ = 0
TSLIB: LastTocRetrieved_ = 0
TSLIB: OutputBitDepth_ = 32
TSLIB: === END CLASS STATE DUMP =========
TSLIB: === BEGIN TOC DATA DUMP ==========
TS: R000,C000: 0x00000000 0x00000000 0x00000000 0x00000000
TS: R000,C001: 0x00000000 0x00000000 0x00000000 0x00000000
.
.
.
TS: R106,C074: 0x00000000 0x00000000 0x00000000 0x00000000
TSLIB: === END TOC DATA DUMP ============
Exception thrown: TS: Tag_[tagBase+row] is NULL (0 case).  tagBase=0, row=0

Unhandled Exception: System.Runtime.InteropServices.SEHException: External component has thrown an exception.
   at MaserDecompTool.NativeMethods.RetrieveTOC(IntPtr Obj)
   at MaserDecompTool.ITsLibWrapper.MaserDecompTool.ITSLib.RetrieveToc()
   at MaserDecompTool.Decomp.TestDecompressDumpedMaserData(String metadata, String binaryData, String outputImage, String outputOM, String rotation, OutputFormat outputImageFormat)
   at MaserDecompTool.Program.Main(String[] args)

Many thanks

Top